Topic: Cant write '@' in Name field for SPF record

Hi there,
According to the documentation, I have to write '@' or leave the field empty in case of creating a SPF record. But, while I am trying to do this, by going through Cpanel>Advance DNS setting, it is not allowing me to leave the 'Name' field empty or to write '@'. It only allows stockboi.com. as valid input for Name field.
How to overcome this?
Regards,
stockboi

Re: Cant write '@' in Name field for SPF record

If you enter the domain name, it is the same as entering @ there.